Internet Message Access Protocol: diferenças entre revisões
Incluindo citações e revisando redação do texto. Mais revisões de texto são necessárias. Mais citações seriam bem vindas |
robô: Arquivamento de 6 URLs |
||
| Linha 4: | Linha 4: | ||
'''IMAP''' ('''''Internet Message Access Protocol'''''. Traduzido do [[Língua inglesa|inglês]], significa "Protocolo de acesso a mensagem da internet") é um [[Protocolo (ciência da computação)|protocolo]] de gerenciamento de [[correio eletrônico]]. |
'''IMAP''' ('''''Internet Message Access Protocol'''''. Traduzido do [[Língua inglesa|inglês]], significa "Protocolo de acesso a mensagem da internet") é um [[Protocolo (ciência da computação)|protocolo]] de gerenciamento de [[correio eletrônico]]. |
||
Utiliza, por padrão, as portas [[Transmission Control Protocol|TCP]] 143 ou 993 (conexão criptografada via [[SSL]])<ref>{{Citar web|url=https://www.iana.org/assignments/service-names-port-numbers/service-names-port-numbers.xhtml?search=imap|titulo=Service Name and Transport Protocol Port Number Registry|acessodata=2017-05-08|obra=www.iana.org}}</ref>. Uma característica peculiar do IMAP é que as mensagens ficam armazenadas em um servidor, e não no computador local de seus usuários.<ref>{{Citar web|url=http://www.washingtonpost.com/wp-dyn/articles/A10089-2004Mar20.html|título=Internet Providers Should Find Their Way to IMAP (washingtonpost.com)|publicado=www.washingtonpost.com|acessodata=23 de abril de 2012}}</ref> Contudo, o protocolo apresenta algumas limitações: |
Utiliza, por padrão, as portas [[Transmission Control Protocol|TCP]] 143 ou 993 (conexão criptografada via [[SSL]])<ref>{{Citar web|url=https://www.iana.org/assignments/service-names-port-numbers/service-names-port-numbers.xhtml?search=imap|titulo=Service Name and Transport Protocol Port Number Registry|acessodata=2017-05-08|obra=www.iana.org|wayb=20250430195342}}</ref>. Uma característica peculiar do IMAP é que as mensagens ficam armazenadas em um servidor, e não no computador local de seus usuários.<ref>{{Citar web|url=http://www.washingtonpost.com/wp-dyn/articles/A10089-2004Mar20.html|título=Internet Providers Should Find Their Way to IMAP (washingtonpost.com)|publicado=www.washingtonpost.com|acessodata=23 de abril de 2012|wayb=20240622074708}}</ref> Contudo, o protocolo apresenta algumas limitações: |
||
* O servidor IMAP cumpre a tarefa de interpretar estes padrões, tornando os clientes mais fáceis de implementar e o acesso mais "universal", bem como pesquisa de texto em mensagens de forma remota. Este modo de trabalho é feito localmente às caixas postais e a seleção para recebimento dos atributos de uma mensagem, ou seu texto ou anexos e outras partes podem ser feitos de forma independente. Então, o usuário pode pedir para receber de uma mensagem com um grande anexo, apenas a parte do texto que lhe interessa, o que é vantajoso no caso de um acesso discado de baixa qualidade e a redução do tráfego em geral.<ref>{{Citar periódico |último=Freed |primeiro=N. |último2=Borenstein |primeiro2=N. |data=1996-11 |título=Multipurpose Internet Mail Extensions (MIME) Part One: Format of Internet Message Bodies |url=https://datatracker.ietf.org/doc/rfc2045/ |doi=10.17487/RFC2045}}</ref>{{Rever redação}} |
* O servidor IMAP cumpre a tarefa de interpretar estes padrões, tornando os clientes mais fáceis de implementar e o acesso mais "universal", bem como pesquisa de texto em mensagens de forma remota. Este modo de trabalho é feito localmente às caixas postais e a seleção para recebimento dos atributos de uma mensagem, ou seu texto ou anexos e outras partes podem ser feitos de forma independente. Então, o usuário pode pedir para receber de uma mensagem com um grande anexo, apenas a parte do texto que lhe interessa, o que é vantajoso no caso de um acesso discado de baixa qualidade e a redução do tráfego em geral.<ref>{{Citar periódico |último=Freed |primeiro=N. |último2=Borenstein |primeiro2=N. |data=1996-11 |título=Multipurpose Internet Mail Extensions (MIME) Part One: Format of Internet Message Bodies |url=https://datatracker.ietf.org/doc/rfc2045/ |doi=10.17487/RFC2045|wayb=20260921004123 }}</ref>{{Rever redação}} |
||
== Vantagens sobre o POP == |
== Vantagens sobre o POP == |
||
| Linha 13: | Linha 13: | ||
=== Vários clientes simultâneos === |
=== Vários clientes simultâneos === |
||
O protocolo POP exige que o cliente atualmente conectado seja o único cliente conectado à [[caixa de correio]]. Por outro lado, o protocolo IMAP permite especificamente o acesso simultâneo de vários clientes e fornece mecanismos para que os clientes detectem as alterações feitas na caixa de correio por outros clientes conectados simultaneamente.<ref>{{Citar periódico |último=Crispin |primeiro=M. |data=2003-03 |ano=2003 |título=INTERNET MESSAGE ACCESS PROTOCOL - VERSION 4rev1 |url=https://datatracker.ietf.org/doc/rfc3501/ |doi=10.17487/RFC3501}}</ref> |
O protocolo POP exige que o cliente atualmente conectado seja o único cliente conectado à [[caixa de correio]]. Por outro lado, o protocolo IMAP permite especificamente o acesso simultâneo de vários clientes e fornece mecanismos para que os clientes detectem as alterações feitas na caixa de correio por outros clientes conectados simultaneamente.<ref>{{Citar periódico |último=Crispin |primeiro=M. |data=2003-03 |ano=2003 |título=INTERNET MESSAGE ACCESS PROTOCOL - VERSION 4rev1 |url=https://datatracker.ietf.org/doc/rfc3501/ |doi=10.17487/RFC3501|wayb=20260608023024 }}</ref> |
||
=== Acesso a partes de mensagens MIME e busca parcial === |
=== Acesso a partes de mensagens MIME e busca parcial === |
||
| Linha 22: | Linha 22: | ||
=== Várias caixas de correio no servidor === |
=== Várias caixas de correio no servidor === |
||
Os clientes IMAP4 podem criar, renomear e / ou excluir caixas de correio (geralmente apresentadas ao usuário como pastas) no servidor e copiar mensagens entre caixas de correio. O suporte a várias caixas de correio também permite que os servidores forneçam acesso a pastas compartilhadas e públicas. A ''extensão da lista de controle de acesso IMAP4 (ACL)'' pode ser usada para regular os direitos de acesso.<ref>{{Citar periódico |último=Melnikov |primeiro=A. |data=2005-12 |título=IMAP4 Access Control List (ACL) Extension |url=https://datatracker.ietf.org/doc/rfc4314/ |doi=10.17487/RFC4314}}</ref> |
Os clientes IMAP4 podem criar, renomear e / ou excluir caixas de correio (geralmente apresentadas ao usuário como pastas) no servidor e copiar mensagens entre caixas de correio. O suporte a várias caixas de correio também permite que os servidores forneçam acesso a pastas compartilhadas e públicas. A ''extensão da lista de controle de acesso IMAP4 (ACL)'' pode ser usada para regular os direitos de acesso.<ref>{{Citar periódico |último=Melnikov |primeiro=A. |data=2005-12 |título=IMAP4 Access Control List (ACL) Extension |url=https://datatracker.ietf.org/doc/rfc4314/ |doi=10.17487/RFC4314|wayb=20260610065740 }}</ref> |
||
=== Pesquisas no servidor === |
=== Pesquisas no servidor === |
||
| Linha 28: | Linha 28: | ||
=== Mecanismo de extensão embutido === |
=== Mecanismo de extensão embutido === |
||
Refletindo a experiência de protocolos anteriores da Internet, o IMAP4 define um mecanismo explícito pelo qual ele pode ser estendido. Muitas extensões IMAP4 ao protocolo base foram propostas e são de uso comum. O IMAP2bis não tinha um mecanismo de extensão, já o POP possui um.<ref>{{Citar periódico |último=Gellens |primeiro=R. |último2=Newman |primeiro2=C. |último3=Lundblade |primeiro3=L. |data=1998-11 |título=POP3 Extension Mechanism |url=https://datatracker.ietf.org/doc/rfc2449/ |doi=10.17487/RFC2449}}</ref> |
Refletindo a experiência de protocolos anteriores da Internet, o IMAP4 define um mecanismo explícito pelo qual ele pode ser estendido. Muitas extensões IMAP4 ao protocolo base foram propostas e são de uso comum. O IMAP2bis não tinha um mecanismo de extensão, já o POP possui um.<ref>{{Citar periódico |último=Gellens |primeiro=R. |último2=Newman |primeiro2=C. |último3=Lundblade |primeiro3=L. |data=1998-11 |título=POP3 Extension Mechanism |url=https://datatracker.ietf.org/doc/rfc2449/ |doi=10.17487/RFC2449|wayb=20260212033430 }}</ref> |
||
'''<big>Por que o IMAP é tão complexo?</big>''' |
'''<big>Por que o IMAP é tão complexo?</big>''' |
||
Revisão das 08h00min de 28 de outubro de 2026
| Pilha de protocolos TCP/IP |
|---|
| Camada de aplicação |
| Camada de transporte |
| Camada de Internet |
| Camada de enlace |
IMAP (Internet Message Access Protocol. Traduzido do inglês, significa "Protocolo de acesso a mensagem da internet") é um protocolo de gerenciamento de correio eletrônico.
Utiliza, por padrão, as portas TCP 143 ou 993 (conexão criptografada via SSL)[1]. Uma característica peculiar do IMAP é que as mensagens ficam armazenadas em um servidor, e não no computador local de seus usuários.[2] Contudo, o protocolo apresenta algumas limitações:
- O servidor IMAP cumpre a tarefa de interpretar estes padrões, tornando os clientes mais fáceis de implementar e o acesso mais "universal", bem como pesquisa de texto em mensagens de forma remota. Este modo de trabalho é feito localmente às caixas postais e a seleção para recebimento dos atributos de uma mensagem, ou seu texto ou anexos e outras partes podem ser feitos de forma independente. Então, o usuário pode pedir para receber de uma mensagem com um grande anexo, apenas a parte do texto que lhe interessa, o que é vantajoso no caso de um acesso discado de baixa qualidade e a redução do tráfego em geral.[3][rever redação]
Vantagens sobre o POP
Modos conectados e desconectados
Ao usar o POP, os clientes geralmente se conectam brevemente ao servidor de e-mail, apenas o tempo necessário para baixar novas mensagens. Ao usar o IMAP4, os clientes geralmente permanecem conectados desde que a interface do usuário esteja ativa e baixem o conteúdo da mensagem sob demanda. Para usuários com muitas ou grandes mensagens, esse padrão de uso IMAP4 pode resultar em tempos de resposta mais rápidos.[4]
Vários clientes simultâneos
O protocolo POP exige que o cliente atualmente conectado seja o único cliente conectado à caixa de correio. Por outro lado, o protocolo IMAP permite especificamente o acesso simultâneo de vários clientes e fornece mecanismos para que os clientes detectem as alterações feitas na caixa de correio por outros clientes conectados simultaneamente.[5]
Acesso a partes de mensagens MIME e busca parcial
Normalmente, todos os emails da Internet são transmitidos no formato MIME , permitindo que as mensagens tenham uma estrutura em árvore, onde os nós folha são de vários tipos de conteúdo de peça única e os nós não folha são de vários tipos de várias partes. O protocolo IMAP4 permite que os clientes recuperem qualquer uma das partes individuais do MIME separadamente e também recuperem partes de partes individuais ou de toda a mensagem. Esses mecanismos permitem que os clientes recuperem a parte do texto de uma mensagem sem recuperar os arquivos anexados ou transmitam o conteúdo conforme ele está sendo buscado.[4]
Informações sobre o estado da mensagem
Através do uso de sinalizadores definidos no protocolo IMAP4, os clientes podem acompanhar o estado da mensagem: por exemplo, se a mensagem foi ou não lida, respondida ou excluída. Esses sinalizadores são armazenados no servidor; portanto, clientes diferentes que acessam a mesma caixa de correio em momentos diferentes podem detectar alterações de estado feitas por outros clientes[4]. O POP não fornece mecanismo para que os clientes armazenem essas informações de estado no servidor; portanto, se um único usuário acessar uma caixa de correio com dois clientes POP diferentes (em momentos diferentes), as informações de estado - como se uma mensagem foi acessada - não poderão ser sincronizadas entre os clientes. O protocolo IMAP4 suporta sinalizadores de sistema predefinidos e palavras-chave definidas pelo cliente. Os sinalizadores do sistema indicam informações de estado, como se uma mensagem foi lida. Palavras-chave, que não são suportadas por todos os servidores IMAP, tags cujo significado depende do cliente. As palavras-chave IMAP não devem ser confundidas com rótulos proprietários de serviços de email baseados na Web , que às vezes são traduzidos em pastas IMAP pelos servidores proprietários correspondentes.[4]
Várias caixas de correio no servidor
Os clientes IMAP4 podem criar, renomear e / ou excluir caixas de correio (geralmente apresentadas ao usuário como pastas) no servidor e copiar mensagens entre caixas de correio. O suporte a várias caixas de correio também permite que os servidores forneçam acesso a pastas compartilhadas e públicas. A extensão da lista de controle de acesso IMAP4 (ACL) pode ser usada para regular os direitos de acesso.[6]
Pesquisas no servidor
O IMAP4 fornece um mecanismo para um cliente solicitar ao servidor que procure mensagens que atendam a vários critérios. Esse mecanismo evita exigir que os clientes baixem todas as mensagens na caixa de correio para realizar essas pesquisas.
Mecanismo de extensão embutido
Refletindo a experiência de protocolos anteriores da Internet, o IMAP4 define um mecanismo explícito pelo qual ele pode ser estendido. Muitas extensões IMAP4 ao protocolo base foram propostas e são de uso comum. O IMAP2bis não tinha um mecanismo de extensão, já o POP possui um.[7]
Por que o IMAP é tão complexo?
O servidor POP3 espera até que um usuário faça logon e então transfere o mensagens não lidas que são salvas na caixa de correio desse usuário para o e-mail do usuário cliente. Dependendo dos requisitos do cliente, as mensagens são excluídas após a transferência para economizar espaço, ou sinalizado como lido e retido.
Isso não é particularmente exigente, por isso não há muito que possa dar errado com o software. Um servidor IMAP funciona de forma diferente: não só entrega e-mails aos usuários, ele também organiza toda a administração de e-mail do usuário final. O e-mail do usuário cliente agora funciona como uma espécie de “controle remoto” para manipular o caixa de correio armazenada no servidor. Um servidor IMAP fornece espaço de armazenamento e armazena todos os e-mails. Por esta razão, faz sentido usar cotas, que forçam os usuários a limpar ocasionalmente e liberar espaço valioso. Quando um usuário cria pastas para seu e mails, o servidor IMAP tem que representar esta estrutura de pastas e ordenar os e-mails correspondentes. O IMAP também permite que os usuários pesquisem mensagens por remetentes ou texto especificados e sinalizar e-mails, por exemplo, como lidos, não lidos ou respondidas.
Um servidor IMAP permite que um usuário gerencie uma caixa de correio de diferentes computadores; o conteúdo da caixa de correio consiste sempre nos mesmos registros de dados não importa de onde seja acessada, e a caixa de correio não precisa ser sincronizado entre as máquinas. A configuração de um servidor IMAP não requer muita atenção do administrador assim que o servidor estiver conectado a um banco de dados do usuário. No entanto, a operação dos servidores IMAP contém algumas armadilhas e dificuldades técnicas, por exemplo, à medida que o número de usuários aumenta, a carga no servidor IMAP se torna perceptível.[4]
Em uma grande organização, o servidor precisa gerenciar milhões de e-mails, operar centenas ou milhares de conexões IMAP em paralelo, e lidar com pesquisas de e-mail e cópias extensas ações. Dependendo do cenário, os servidores IMAP podem consumir RAM ou criar altas cargas de E/S nos suportes de dados. Além disso, quando um servidor IMAP faz parte de um cluster de servidor, não é mais suficiente usar um disco rígido conectado diretamente como disco para armazenamento. Implementar restrições de armazenamento como cotas nem sempre é fácil e requer um planejamento preciso.
Referências
- ↑ «Service Name and Transport Protocol Port Number Registry». www.iana.org. Consultado em 8 de maio de 2017. Cópia arquivada em 30 de abril de 2025
- ↑ «Internet Providers Should Find Their Way to IMAP (washingtonpost.com)». www.washingtonpost.com. Consultado em 23 de abril de 2012. Cópia arquivada em 22 de junho de 2024
- ↑ Freed, N.; Borenstein, N. (novembro de 1996). «Multipurpose Internet Mail Extensions (MIME) Part One: Format of Internet Message Bodies». doi:10.17487/RFC2045. Cópia arquivada em 21 de setembro de 2026
- 1 2 3 4 5 Kurose, James F. (29 de maio de 2013). Redes de computadores e a internet: uma abordagem top-down. 6. Keith W. Ross. São Paulo: Pearson. ISBN 978-85-8143-677-7. Consultado em 27 de outubro de 2026
- ↑ Crispin, M. (março de 2003). «INTERNET MESSAGE ACCESS PROTOCOL - VERSION 4rev1». doi:10.17487/RFC3501. Cópia arquivada em 8 de junho de 2026
- ↑ Melnikov, A. (dezembro de 2005). «IMAP4 Access Control List (ACL) Extension». doi:10.17487/RFC4314. Cópia arquivada em 10 de junho de 2026
- ↑ Gellens, R.; Newman, C.; Lundblade, L. (novembro de 1998). «POP3 Extension Mechanism». doi:10.17487/RFC2449. Cópia arquivada em 12 de fevereiro de 2026
Ver também
- Internet Mail 2000, proposta alternativa ao SMTP