Sari la conținut

Internet Message Access Protocol: Diferență între versiuni

De la Wikipedia, enciclopedia liberă
Conținut șters Conținut adăugat
m Profesorul Blazat a redenumit pagina IMAP în Internet Message Access Protocol: Uniformizare ca parte a unui set de pagini
Completare
 
Linia 1: Linia 1:
În [[informatică]]''',''' '''Internet Message Access Protocol''' ('''IMAP''', în {{Ro|Protocol de Acces la Mesaje Internet}}) este un [[Internet Protocol|protocol standard al Internetului]] folosit de [[Client de e-mail|clienții de e-mail]] pentru a prelua mesaje de [[e-mail]] de pe un [[server]] de mail printr-o conexiune [[TCP/IP]]. IMAP este definit de <nowiki>RFC 9051</nowiki>.<ref>{{Citation|last=Dean|first=Tamara|title=Network+ guide to networks|date=2010|edition=5th ed|publisher=Course TechnologyCengage Learning|isbn=978-1-4239-0245-4|access-date=2026-01-01}}</ref>
'''Protocolul de Acces la Mesaje Internet''' (în engleză '''Internet Message Access Protocol''', abreviat '''IMAP''' - denumit și '''Interactive Mail Access Protocol''') permite accesul la mesaje din foldere de [[e-mail]] de pe un [[server]]. Spre deosebire de [[POP3]], care este proiectat pentru a transfera și șterge e-mail-urile de pe server, scopul IMAP este de a le stoca pe toate pe server, pentru a putea fi oricând accesate din orice loc.


IMAP a fost conceput cu scopul de a permite administrarea completă a unei căsuțe poștale de către mai mulți clienți de e-mail. Un server IMAP ascultă de obicei pe [[Port (rețea)|portul]] 143. IMAP peste [[Transport Layer Security|SSL/TLS]] (IMAPS) este atribuit portului 993. Practic toți clienții și serverele moderne de e-mail suportă IMAP, care, alături de protocolul mai vechi [[POP3]] (Post Office Protocol), reprezintă cele două cele mai răspândite [[Internet Protocol|protocoale standard]] pentru preluarea e-mailului. Multe servicii de webmail, precum [[Gmail]] și [[Outlook]], acceptă atât IMAP, cât și [[POP3]].<ref>{{Citation|last=Garfinkel|first=Simson|title=Practical UNIX and Internet security|date=2003|edition=3rd ed|publisher=O'Reilly|isbn=978-0-596-00323-4|access-date=2026-01-01|last2=Spafford|first2=Gene|last3=Schwartz|first3=Alan}}</ref><ref>{{Citation|title=Securing Windows 2000 Advanced Server and Red Hat Linux 6 for E-mail Services|date=2000|url=https://doi.org/10.1016/b978-192899423-7/50012-4|work=E-Mail Virus Protection Handbook|pages=295–332|publisher=Elsevier|isbn=978-1-928994-23-7|access-date=2026-01-01}}</ref><ref>{{Citation|last=Blum|first=Richard|title=Open source e-mail security|date=2002|publisher=SAMS|isbn=978-0-672-32237-2|access-date=2026-01-01}}</ref>
Internet Message Access Protocol (denumit uzual IMAP) este un protocol de [[nivel aplicație]] ce permite unui [[client de mail|client]] accesul la [[E-mail|e-mail]] pe un server de mail. Versiunea curentă, IMAP versiunea 4, revizia 1 (IMAP4rev1) este definită de RFC 3501. Un server IMAP poate asculta pe portul de contact 143. IMAP peste SSL (IMAPS) are asociat portul de contact 993.

== Exemplu de dialog ==
Acesta este un exemplu de conexiune IMAP, așa cum este preluat din [https://tools.ietf.org/html/rfc3501#section-8 RFC 3501 secțiunea 8]:
<span style="color:blue;">C: <open connection></span>
S: * OK IMAP4rev1 Service Ready
<span style="color:blue;">C: a001 login mrc secret</span>
S: a001 OK LOGIN completed
<span style="color:blue;">C: a002 select inbox</span>
S: * 18 EXISTS
S: * FLAGS (\Answered \Flagged \Deleted \Seen \Draft)
S: * 2 RECENT
S: * OK [UNSEEN 17] Message 17 is the first unseen message
S: * OK [UIDVALIDITY 3857529045] UIDs valid
S: a002 OK [READ-WRITE] SELECT completed
<span style="color:blue;">C: a003 fetch 12 full</span>
S: * 12 FETCH (FLAGS (\Seen) INTERNALDATE "17-Jul-1996 02:44:25 -0700"
RFC822.SIZE 4286 ENVELOPE ("Wed, 17 Jul 1996 02:23:25 -0700 (PDT)"
"IMAP4rev1 WG mtg summary and minutes"
(("Terry Gray" NIL "gray" "cac.washington.edu"))
(("Terry Gray" NIL "gray" "cac.washington.edu"))
(("Terry Gray" NIL "gray" "cac.washington.edu"))
((NIL NIL "imap" "cac.washington.edu"))
((NIL NIL "minutes" "CNRI.Reston.VA.US")
("John Klensin" NIL "KLENSIN" "MIT.EDU")) NIL NIL
BODY ("TEXT" "PLAIN" ("CHARSET" "US-ASCII") NIL NIL "7BIT" 3028
92))
S: a003 OK FETCH completed
<span style="color:blue;">C: a004 fetch 12 body[header]</span>
S: * 12 FETCH (BODY[HEADER] {342}
S: {{codett|Date: Wed, 17 Jul 1996 02:23:25 -0700 (PDT)|email}}
S: {{codett|From: Terry Gray <[email protected]>|email}}
S: {{codett|Subject: IMAP4rev1 WG mtg summary and minutes|email}}
S: {{codett|To: [email protected]|email}}
S: {{codett|Cc: [email protected], John Klensin <[email protected]>|email}}
S: {{codett|Message-Id: <[email protected]>|email}}
S: {{codett|MIME-Version: 1.0|email}}
S: {{codett|1=Content-Type: TEXT/PLAIN; CHARSET=US-ASCII|2=email}}
S:
S: )
S: a004 OK FETCH completed
<span style="color:blue;">C a005 store 12 +flags \deleted</span>
S: * 12 FETCH (FLAGS (\Seen \Deleted))
S: a005 OK +FLAGS completed
<span style="color:blue;">C: a006 logout</span>
S: * BYE IMAP4rev1 server terminating connection
S: a006 OK LOGOUT completed

== Note ==
<references />


==Vezi și==
==Vezi și==
⚫
[[POP3]]


⚫
* [[POP3]]
* [[Webmail]]
{{Control de autoritate}}
{{Control de autoritate}}
{{ciot-informatică}}
{{ciot-informatică}}

Versiunea curentă din 2 ianuarie 2026 01:50

În informatică, Internet Message Access Protocol (IMAP, în română Protocol de Acces la Mesaje Internet) este un protocol standard al Internetului folosit de clienții de e-mail pentru a prelua mesaje de e-mail de pe un server de mail printr-o conexiune TCP/IP. IMAP este definit de RFC 9051.[1]

IMAP a fost conceput cu scopul de a permite administrarea completă a unei căsuțe poștale de către mai mulți clienți de e-mail. Un server IMAP ascultă de obicei pe portul 143. IMAP peste SSL/TLS (IMAPS) este atribuit portului 993. Practic toți clienții și serverele moderne de e-mail suportă IMAP, care, alături de protocolul mai vechi POP3 (Post Office Protocol), reprezintă cele două cele mai răspândite protocoale standard pentru preluarea e-mailului. Multe servicii de webmail, precum Gmail și Outlook, acceptă atât IMAP, cât și POP3.[2][3][4]

Exemplu de dialog

[modificare | modificare sursă]

Acesta este un exemplu de conexiune IMAP, așa cum este preluat din RFC 3501 secțiunea 8:

C: <open connection>
S:   * OK IMAP4rev1 Service Ready
C:   a001 login mrc secret
S:   a001 OK LOGIN completed
C:   a002 select inbox
S:   * 18 EXISTS
S:   * FLAGS (\Answered \Flagged \Deleted \Seen \Draft)
S:   * 2 RECENT
S:   * OK [UNSEEN 17] Message 17 is the first unseen message
S:   * OK [UIDVALIDITY 3857529045] UIDs valid
S:   a002 OK [READ-WRITE] SELECT completed
C:   a003 fetch 12 full
S:   * 12 FETCH (FLAGS (\Seen) INTERNALDATE "17-Jul-1996 02:44:25 -0700"
      RFC822.SIZE 4286 ENVELOPE ("Wed, 17 Jul 1996 02:23:25 -0700 (PDT)"
      "IMAP4rev1 WG mtg summary and minutes"
      (("Terry Gray" NIL "gray" "cac.washington.edu"))
      (("Terry Gray" NIL "gray" "cac.washington.edu"))
      (("Terry Gray" NIL "gray" "cac.washington.edu"))
      ((NIL NIL "imap" "cac.washington.edu"))
      ((NIL NIL "minutes" "CNRI.Reston.VA.US")
      ("John Klensin" NIL "KLENSIN" "MIT.EDU")) NIL NIL
      "<[email protected]>")
      BODY ("TEXT" "PLAIN" ("CHARSET" "US-ASCII") NIL NIL "7BIT" 3028
      92))
S:   a003 OK FETCH completed
C:   a004 fetch 12 body[header]
S:   * 12 FETCH (BODY[HEADER] {342}
S:   Date: Wed, 17 Jul 1996 02:23:25 -0700 (PDT)
S:   From: Terry Gray <[email protected]>
S:   Subject: IMAP4rev1 WG mtg summary and minutes
S:   To: [email protected]
S:   Cc: [email protected], John Klensin <[email protected]>
S:   Message-Id: <[email protected]>
S:   MIME-Version: 1.0
S:   Content-Type: TEXT/PLAIN; CHARSET=US-ASCII
S:
S:   )
S:   a004 OK FETCH completed
C    a005 store 12 +flags \deleted
S:   * 12 FETCH (FLAGS (\Seen \Deleted))
S:   a005 OK +FLAGS completed
C:   a006 logout
S:   * BYE IMAP4rev1 server terminating connection
S:   a006 OK LOGOUT completed
  1. ↑ Dean, Tamara (), Network+ guide to networks (ed. 5th ed), Course TechnologyCengage Learning, ISBN 978-1-4239-0245-4
  2. ↑ Garfinkel, Simson; Spafford, Gene; Schwartz, Alan (), Practical UNIX and Internet security (ed. 3rd ed), O'Reilly, ISBN 978-0-596-00323-4
  3. ↑ „Securing Windows 2000 Advanced Server and Red Hat Linux 6 for E-mail Services”, E-Mail Virus Protection Handbook, Elsevier, pp. 295–332, , ISBN 978-1-928994-23-7, accesat în
  4. ↑ Blum, Richard (), Open source e-mail security, SAMS, ISBN 978-0-672-32237-2