본문으로 이동

IPv6 패킷

위키백과, 우리 모두의 백과사전.

IPv6 패킷(IPv6 packet)은 인터넷 프로토콜 버전 6(IPv6)을 사용하여 교환되는 가장 작은 메시지 단위이다. 패킷은 주소 지정 및 라우팅을 위한 제어 정보와 사용자 데이터인 페이로드로 구성된다. IPv6 패킷의 제어 정보는 필수적인 고정 헤더와 선택적 확장 헤더로 세분화된다. IPv6 패킷의 페이로드는 일반적으로 상위 전송 계층 프로토콜의 데이터그램이나 세그먼트이지만, 때로는 인터넷 계층(예: ICMPv6)이나 링크 계층(예: OSPF)을 위한 데이터일 수도 있다.

IPv6 패킷은 일반적으로 링크 계층(예: 이더넷 또는 와이파이)을 통해 전송되며, 각 패킷은 프레임으로 캡슐화된다. 또한 패킷은 6to4나 테레도 전환 기술을 사용할 때의 IPv4와 같은 상위 계층 터널링 프로토콜을 통해 전송될 수도 있다.

IPv4와 달리 라우터는 최대 전송 단위(MTU)보다 큰 IPv6 패킷을 단편화하지 않으며, 이는 전적으로 발신 노드의 책임이다. IPv6에서는 최소 1,280 옥텟의 MTU를 의무화하고 있으나, 호스트가 최소값보다 큰 MTU를 활용할 수 있도록 경로 MTU 탐색을 사용하는 것을 "강력히 권장"한다.[1]

2017년 7월부터 IANA는 IPv6 패킷 헤더에 사용되는 모든 IPv6 매개변수를 등록하는 책임을 맡고 있다.[1]

고정 헤더

[편집]

고정 헤더는 IPv6 패킷의 시작 부분에 위치하며 크기는 40 옥텟(320 비트)이다.[1] 다중 바이트 필드의 바이트는 네트워크 바이트 순서를 따른다.

고정 헤더 형식
오프셋 옥텟 0 1 2 3
옥텟 비트 0 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31
0 0 버전 트래픽 클래스 플로우 레이블
4 32 페이로드 길이 다음 헤더 홉 제한
8 64 발신지 주소
12 96
16 128
20 160
24 192 목적지 주소
28 224
32 256
36 288
버전: 4비트:상수 6 (비트 시퀀스 0110).
트래픽 클래스: 6+2비트:이 필드의 비트는 두 가지 값을 가진다. 상위 6비트는 패킷을 분류하는 데 사용되는 차등 서비스 필드(DS 필드)를 담고 있다.[2][3] 현재 모든 표준 DS 필드는 '0' 비트로 끝난다. 두 개의 '1' 비트로 끝나는 DS 필드는 로컬 또는 실험적 용도로 의도된 것이다.[4] 나머지 2비트는 명시적 혼잡 알림(ECN)에 사용된다.[5] 우선순위 값은 발신지가 혼잡 제어를 제공하는 트래픽과 그렇지 않은 트래픽 범위로 세분화된다.
플로우 레이블: 20비트:발신지와 목적지 간 패킷 흐름의 고엔트로피 식별자. 흐름은 TCP 세션이나 미디어 스트림과 같은 패킷 그룹이다. 특수 플로우 레이블 0은 해당 패킷이 (이 체계를 사용하는) 어떤 흐름에도 속하지 않음을 의미한다. 구형 체계에서는 발신지 주소와 포트, 목적지 주소와 포트, 프로토콜(마지막 다음 헤더 필드의 값)로 흐름을 식별한다.[6] 또한 플로우 레이블을 사용하여 스푸핑된 패킷을 탐지하는 데 도움을 줄 수 있다는 제안이 있다.[7]
페이로드 길이: 16비트:모든 확장 헤더를 포함한 페이로드의 크기(옥텟 단위). 홉-바이-홉 확장 헤더가 점보 페이로드 옵션을 가질 경우 길이는 0으로 설정된다.[8]
다음 헤더: 8비트:다음 헤더의 유형을 지정한다. 이 필드는 일반적으로 패킷 페이로드가 사용하는 전송 계층 프로토콜을 지정한다. 패킷에 확장 헤더가 존재할 경우, 이 필드는 뒤따르는 확장 헤더가 무엇인지 나타낸다. 값은 IPv4 프로토콜 필드에 사용되는 값과 공유되며, 두 필드는 동일한 기능을 한다(참조: IP 프로토콜 번호 목록).
홉 제한: 8비트:IPv4의 타임 투 리브 필드를 대체한다. 이 값은 각 전달 노드에서 1씩 감소하며, 0이 되면 패킷이 폐기된다. 단, 목적지 노드는 홉 제한이 0인 상태로 수신되더라도 패킷을 정상적으로 처리해야 한다.
발신지 주소: 128비트:전송 노드의 유니캐스트 IPv6 주소.
목적지 주소: 128비트:목적지 노드(들)의 IPv6 유니캐스트 또는 멀티캐스트 주소.

성능을 향상시키기 위해, 그리고 현재의 링크 계층 기술과 전송 계층 프로토콜이 충분한 오류 탐지 기능을 제공한다고 가정하므로,[9] 헤더에는 이를 보호하기 위한 체크섬이 없다.[1]

확장 헤더

[편집]

확장 헤더는 선택적인 인터넷 계층 정보를 담고 있으며 고정 헤더와 상위 계층 프로토콜 헤더 사이에 위치한다.[1] 확장 헤더는 '다음 헤더' 필드를 사용하여 체인을 형성한다. 고정 헤더의 '다음 헤더' 필드는 첫 번째 확장 헤더의 유형을 나타내며, 마지막 확장 헤더의 '다음 헤더' 필드는 패킷 페이로드에 있는 상위 계층 프로토콜 헤더의 유형을 나타낸다. 모든 확장 헤더는 8옥텟의 배수 크기를 가지며, 일부 확장 헤더는 이 요구 사항을 충족하기 위해 내부 패딩이 필요하다.

여러 확장 헤더가 정의되어 있으며 향후 새로운 확장 헤더가 정의될 수 있다. 대부분의 확장 헤더는 패킷의 목적지에서 검사 및 처리된다. '홉-바이-홉 옵션'은 중간 노드에서 처리 및 수정될 수 있으며, 존재할 경우 반드시 첫 번째 확장 헤더여야 한다. 모든 확장 헤더는 선택 사항이며 최대 한 번만 나타나야 한다. 단, 목적지 옵션 헤더 확장은 두 번까지 나타날 수 있다.[1]

노드가 특정 확장 헤더를 인식하지 못할 경우, 패킷을 폐기하고 매개변수 문제 메시지(ICMPv6 유형 4, 코드 1)를 전송해야 한다.[1]

아래 정의된 확장 헤더들은 고정 헤더 뒤에 두 개 이상의 확장 헤더가 올 경우 권장되는 순서대로 나열되어 있다.

확장 헤더 다음 헤더 필드 값 설명
홉-바이-홉 옵션 0경로상의 모든 장치가 검사해야 하는 옵션
라우팅 43데이터그램의 경로를 지정하는 방법(모바일 IPv6와 함께 사용)
단편화 44데이터그램 단편화를 위한 매개변수 포함
인증 헤더(AH) 51패킷 대부분의 진위 여부를 확인하는 데 사용되는 정보 포함
보안 페이로드 캡슐화(ESP) 50보안 통신을 위한 암호화된 데이터 전송
목적지 옵션 (상위 계층 헤더 앞) 60패킷의 목적지만 검사하면 되는 옵션
이동성 (현재 상위 계층 헤더 없음) 135모바일 IPv6와 함께 사용되는 매개변수
호스트 식별 프로토콜139호스트 식별 프로토콜 버전 2(HIPv2)에 사용[10]
Shim6 프로토콜140Shim6에 사용[11]
예약됨253실험 및 테스트용[12][4]
예약됨254실험 및 테스트용[12][4]

'다음 헤더' 필드의 값 59(다음 헤더 없음)는 이 헤더 뒤에 어떠한 다음 헤더도 없음을 나타내며, 상위 계층 프로토콜의 헤더조차 없음을 의미한다. 즉, 헤더 관점에서는 IPv6 패킷이 그 직후에 끝난다는 뜻이며 페이로드는 비어 있어야 한다. 그러나 패킷의 첫 번째 헤더에 있는 페이로드 길이가 패킷 내 모든 확장 헤더의 길이를 합친 것보다 크다면 페이로드에 데이터가 여전히 존재할 수 있다. 이 데이터는 호스트가 무시해야 하지만, 라우터는 변경 없이 전달해야 한다.[1]: 4.7 

홉-바이-홉 옵션 및 목적지 옵션

[편집]

홉-바이-홉 옵션 확장 헤더는 송신 노드와 수신 노드를 포함하여 패킷 경로상의 모든 노드가 검사하고 변경할 수 있다. (인증을 위해, 경로를 따라 변경될 수 있는 옵션 값은 무시된다.) 목적지 옵션 확장 헤더는 목적지 노드(들)만 검사하면 된다. 두 확장 헤더 모두 최소 8옥텟 크기이다. 해당 공간에 수용할 수 있는 것보다 많은 옵션이 있으면, 옵션과 패딩을 포함한 8옥텟 블록이 모든 옵션이 표현될 때까지 헤더에 반복적으로 추가된다.

홉-바이-홉 옵션 및 목적지 옵션 확장 헤더 형식
오프셋 옥텟 0 1 2 3
옥텟 비트 0 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31
0 0 다음 헤더 헤더 확장 길이 옵션 및 패딩
4 32 옵션 및 패딩
8 64 선택 사항: 추가 옵션 및 패딩
12 96
⋮ ⋮
다음 헤더: 8비트:다음 헤더의 유형을 지정한다.
헤더 확장 길이: 8비트:첫 8옥텟을 제외한 이 헤더의 길이를 8옥텟 단위로 표시.
옵션 및 패딩: 가변:하나 이상의 옵션과, 옵션을 정렬하고 전체 헤더 길이를 8옥텟의 배수로 만들기 위한 선택적 패딩 필드를 포함한다. 옵션은 TLV로 코딩된다.

라우팅

[편집]

라우팅 확장 헤더는 패킷을 목적지로 보내기 전에 하나 이상의 중간 노드로 유도하는 데 사용된다. 헤더는 최소 8옥텟 크기이며, 4옥텟에 수용할 수 있는 것보다 더 많은 유형별 데이터가 필요한 경우 모든 유형별 데이터가 배치될 때까지 8옥텟 블록이 헤더에 반복적으로 추가된다.[1]

라우팅 확장 헤더 형식
오프셋 옥텟 0 1 2 3
옥텟 비트 0 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31
0 0 다음 헤더 헤더 확장 길이 라우팅 유형 남은 세그먼트
4 32 유형별 데이터
8 64 선택 사항: 추가 유형별 데이터...
12 96
⋮ ⋮
다음 헤더: 8비트:다음 헤더의 유형을 나타낸다.
헤더 확장 길이: 8비트:첫 8옥텟을 제외한 이 헤더의 길이를 8옥텟 단위로 표시.
라우팅 유형: 8비트:IANA가 할당한 0에서 255 사이의 값.[13]
유형 상태 비고
0 폐기됨 라우팅 헤더 유형 0으로 인해 단순하면서도 효과적인 서비스 거부 공격이 가능해짐에 따라,[14] 이 헤더는 2007년에 폐기되었으며 호스트와 라우터는 이 헤더를 무시해야 한다.[15]
1 폐기됨 방위고등연구계획국(DARPA)이 자금을 지원한 Nimrod 프로젝트에 사용되었으며 2009년에 폐기되었다.[16]
2 허용됨 유형 0의 제한적 버전으로 모바일 IPv6에 사용되며, 이동 노드의 홈 주소를 담을 수 있다.
3 허용됨 저전력 및 손실 네트워크를 위한 RPL 소스 경로 헤더[17]
4 허용됨 세그먼트 라우팅 헤더(SRH).[18]
253개인용 실제 구현이 아닌 테스트용으로 사용될 수 있음. RFC3692 방식 실험 1.[12]
254개인용 실제 구현이 아닌 테스트용으로 사용될 수 있음. RFC3692 방식 실험 2.[12]
남은 세그먼트: 8비트:최종 목적지에 도달하기 위해 패킷이 방문해야 하는 남은 노드 수.
유형별 데이터: 가변:이 유형의 라우팅 헤더에 속하는 데이터.

단편화

[편집]

경로 MTU보다 큰 패킷을 보내기 위해 송신 노드는 패킷을 조각(fragment)으로 나눈다. 단편화 확장 헤더는 원래의(단편화되지 않은) 패킷을 재조합하는 데 필요한 정보를 담고 있다.[1]

단편화 확장 헤더 형식
오프셋 옥텟 0 1 2 3
옥텟 비트 0 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31
0 0 다음 헤더 예약됨 단편 오프셋 Res M
4 32 식별자
다음 헤더: 8비트:다음 헤더의 유형을 식별한다.
예약됨: 8비트; 예약됨 == 0:모두 0으로 초기화됨.
단편 오프셋: 13비트:원래 패킷의 단편화 가능한 부분 시작점에 상대적인 오프셋(8옥텟 단위).
예약됨2 (Res): 2비트; Res == 0:예약됨; 0으로 초기화됨.
M 플래그 (M): 1비트:1은 더 많은 단편이 뒤따름을 의미, 0은 마지막 단편을 의미.
식별자: 32비트:송신 노드에 의해 생성된 패킷 식별 값. 원래 패킷의 재조합에 필요.

인증 헤더(AH) 및 보안 페이로드 캡슐화(ESP)

[편집]

인증 헤더와 보안 페이로드 캡슐화는 IPsec의 일부이며 IPv6와 IPv4에서 동일하게 사용된다.[19][20]

페이로드

[편집]

고정 및 선택적 IPv6 헤더 뒤에는 상위 계층 페이로드(예: TCP 세그먼트나 UDP 데이터그램 등 전송 계층에서 제공하는 데이터)가 따른다. 마지막 IPv6 헤더의 '다음 헤더' 필드는 이 패킷에 포함된 페이로드 유형을 나타낸다.

표준 페이로드 길이

[편집]

IPv6(및 IPv4)의 페이로드 길이 필드는 16비트 크기로, 페이로드에 대해 최대 65535 옥텟의 길이를 지정할 수 있다. 실제로 호스트는 패킷 단편화를 방지하기 위해 경로 MTU 탐색(송신자에서 수신자까지의 경로 중 최소 MTU를 산출)을 사용하여 최대 사용 가능 페이로드 길이를 결정한다. 대부분의 링크 계층 프로토콜은 MTU가 65535 옥텟보다 훨씬 작다.

점보그램

[편집]

IPv6의 선택적 기능인 홉-바이-홉 옵션 확장 헤더의 점보 페이로드 옵션[8]은 32비트 길이 필드를 사용하여 최대 4기가바이트에서 1옥텟을 뺀 크기(232 − 1 = 4294967295 옥텟)의 페이로드를 가진 패킷을 교환할 수 있게 한다. 이러한 페이로드를 가진 패킷을 점보그램이라고 부른다.

TCP와 UDP 모두 16비트로 제한된 필드(길이, 긴급 데이터 포인터 등)를 포함하고 있으므로, IPv6 점보그램을 지원하려면 전송 계층 프로토콜 구현에 수정이 필요하다.[8] 점보그램은 MTU가 65583 옥텟보다 큰 링크에서만 의미가 있다(페이로드 65535 옥텟 + 고정 헤더 40 옥텟 + 홉-바이-홉 확장 헤더 8 옥텟 이상). 65535 옥텟보다 큰 패킷을 처리할 수 있는 링크 계층 프로토콜은 거의 없다.

단편화

[편집]

IPv4와 달리 IPv6 라우터는 IPv6 패킷을 절대로 단편화하지 않는다. 목적지 링크의 최대 전송 단위(MTU)를 초과하는 패킷은 폐기되며, 이 상황은 IPv4의 Don't Fragment 비트가 설정되었을 때와 유사하게 발신 노드에 'Packet too big' ICMPv6 메시지로 알린다.[1] IPv6 종단 노드는 전송할 패킷의 최대 크기를 결정하기 위해 경로 MTU 탐색을 수행해야 하며, 상위 계층 프로토콜이 페이로드 크기를 제한해야 한다. 상위 계층 프로토콜이 이를 수행할 수 없는 경우, 송신 호스트는 단편화 확장 헤더를 대신 사용할 수 있다.

IPv6 데이터를 전달하는 모든 데이터 링크 계층은 최대 1,280바이트를 포함하는 IP 패킷을 전송할 수 있어야 한다. 따라서 송신단은 패킷 크기를 1,280바이트로 제한하여 단편화나 경로 MTU 탐색이 필요하지 않게 만들 수 있다.

단편화 과정

[편집]

원래의 (더 큰) 패킷 중 첫 번째 단편을 포함하는 패킷은 다섯 부분으로 구성된다. 단편별 헤더(각 단편마다 반복적으로 사용되는 중요한 원본 헤더), 단편 오프셋이 0인 단편화 확장 헤더, 나머지 원본 확장 헤더들, 원본 상위 계층 헤더(또는 ESP 헤더), 그리고 원본 페이로드의 일부이다.[1] 각 후속 패킷은 단편별 헤더, 단편화 확장 헤더, 그리고 단편 오프셋으로 식별되는 원본 페이로드의 일부로 구성된다.

단편별 헤더는 원본에 라우팅 또는 홉-바이-홉 확장 헤더가 포함되어 있는지에 따라 결정된다. 둘 다 없으면 단편별 부분은 고정 헤더뿐이다. 라우팅 확장 헤더가 있으면 단편별 헤더에는 고정 헤더와 라우팅 헤더까지의 모든 확장 헤더가 포함된다. 홉-바이-홉 확장 헤더가 있으면 단편별 헤더는 고정 헤더와 홉-바이-홉 확장 헤더만으로 구성된다.

어떤 경우든 단편별 부분의 마지막 헤더에는 다음 헤더 값이 44로 설정되어 단편화 확장 헤더가 뒤따름을 나타낸다. 각 단편화 확장 헤더의 M 플래그는 마지막 단편(0으로 설정)을 제외하고 모두 1(더 많은 단편이 뒤따름을 나타냄)로 설정된다. 각 단편의 길이는 마지막 단편을 제외하고는 모두 8옥텟의 배수이다.

단편별 헤더는 역사적으로 "단편화 불가능한 부분"이라 불렸으나, 이는 2014년 이전의 헤더 나머지 부분을 단편화할 가능성을 염두에 둔 표현이었다. 현재는 실제로 단편화할 수 있는 헤더는 없다.[21]

재조합

[편집]

원본 패킷은 수신 노드가 모든 단편을 수집하여 각 단편을 지시된 오프셋에 배치하고 단편을 나르던 단편화 확장 헤더를 폐기함으로써 재조합된다. 단편을 포함하는 패킷은 반드시 순서대로 도착할 필요는 없으며, 수신 노드에서 재정렬된다.

첫 번째 단편을 받은 후 60초 이내에 모든 단편이 수신되지 않으면 원본 패킷의 재조합은 포기되고 모든 단편은 폐기된다. (고정 헤더를 포함하는) 첫 번째 단편은 수신되었으나 다른 단편들이 누락된 경우, 단편화된 패킷을 보낸 노드로 시간 초과 메시지(ICMPv6 유형 3, 코드 1)가 반환된다.

재조합 노드가 다른 단편과 겹치는 단편을 감지하면 원본 패킷 재조합은 중단되고 모든 단편이 삭제된다. 노드는 선택적으로 동일한 단편의 중복본을 서로 겹치는 것으로 처리하는 대신 무시할 수 있다.[1]

수신 호스트는 재조합 후 최대 1500바이트가 되는 단편화된 IP 데이터그램을 재조합하기 위해 최선을 다해야 한다. 호스트는 1500바이트보다 큰 단편화된 데이터그램을 재조합하려고 시도할 수 있으나, 재조합된 패킷이 1500바이트를 넘을 것이 명백해지면 패킷을 자동으로 폐기할 수 있다. 따라서 수신자가 그러한 대형 데이터그램을 재조합할 수 있다는 것을 알지 못하는 한, 송신자는 총 재조합 크기가 1500바이트를 넘는 단편화된 IP 데이터그램을 보내지 말아야 한다.

보안

[편집]

연구에 따르면 단편화를 사용하여 네트워크 보안 제어를 우회할 수 있음이 밝혀졌다. 그 결과, 2014년에 틈새 형태의 병리적 단편화 사례를 피하기 위해 첫 번째 단편을 넘어 IPv6 헤더 체인을 오버플로시키는 기존의 허용 방식이 금지되었다.[21] 또한 Router Advertisement Guard 우회에 관한 연구 결과에 따라,[22] 이웃 탐색 프로토콜과 함께 단편화를 사용하는 것은 폐기되었으며, Secure Neighbor Discovery(SEND)와 단편화를 함께 사용하는 것도 권장되지 않는다.[23]

각주

[편집]
  1. 1 2 3 4 5 6 7 8 9 10 11 12 13 S. Deering; R. Hinden (July 2017). Internet Protocol, Version 6 (IPv6) Specification. Internet Engineering Task Force. STD 86. RFC 8200. https://tools.ietf.org/html/rfc8200. Internet Standard 86. Obsoletes RFC 2460.
  2. ↑ K. Nichols; S. Blake; F. Baker; D. Black (December 1998). Definition of the Differentiated Services Field (DS Field) in the IPv4 and IPv6 Headers. Network Working Group. RFC 2474. https://tools.ietf.org/html/rfc2474. Proposed Standard. Obsoletes RFC 1455 and 1349. Updated by RFC 3168, 3260 and 8436.
  3. ↑ D. Grossman (April 2002). New Terminology and Clarifications for DiffServ. RFC 3260. https://tools.ietf.org/html/rfc3260. Informational. Updates RFC 2474, 2475 and 2597.
  4. 1 2 3 B. Fenner (November 2006). Experimental Values in IPv4, IPv6, ICMPv4, ICMPv6, UDP, and TCP Headers. IETF Network Working Group. RFC 4727. https://tools.ietf.org/html/rfc4727. Proposed Standard.
  5. ↑ K. Ramakrishnan; S. Floyd; D. Black (September 2001). The Addition of Explicit Congestion Notification (ECN) to IP. Network Working Group. RFC 3168. https://tools.ietf.org/html/rfc3168. Proposed Standard. Obsoletes RFC 2481. Updates RFC 2474, 2401 and 793. Updated by RFC 4301, 6040 and 8311.
  6. ↑ S. Amante; B. Carpenter; S. Jiang; J. Rajahalme (November 2011). IPv6 Flow Label Specification. Internet Engineering Task Force. ISSN 2070-1721. RFC 6437. https://tools.ietf.org/html/rfc6437. Proposed Standard. Obsoletes RFC 3697. Updates RFC 2205 and 2460.
  7. ↑ Use of the IPv6 Flow Label as a Transport-Layer Nonce to Defend Against Off-Path Spoofing Attacks
  8. 1 2 3 D. Borman; S. Deering; R. Hinden (August 1999). IPv6 Jumbograms. Network Working Group. RFC 2675. https://tools.ietf.org/html/rfc2675. Proposed Standard. Obsoletes RFC 2147.
  9. ↑ C. Partridge; F. Kastenholz (December 1994). Technical Criteria for Choosing IP The Next Generation (IPng). Network Working Group. RFC 1726. https://tools.ietf.org/html/rfc1726. Informational. sec. 2.6.
  10. ↑ T. Heer; P. Jokela; T. Henderson (April 2015). R. Moskowitz. ed. Host Identity Protocol Version 2 (HIPv2). Internet Engineering Task Force (IETF). ISSN 2070-1721. RFC 7401. https://tools.ietf.org/html/rfc7401. Proposed Standard. Obsoletes RFC 5201. Updated by RFC 8002 and 9374.
  11. ↑ E. Nordmark; M. Bagnulo (June 2009). Shim6: Level 3 Multihoming Shim Protocol for IPv6. Internet Engineering Task Force Networking Working Group. RFC 5533. https://tools.ietf.org/html/rfc5533. Proposed Standard.
  12. 1 2 3 4 T. Narten (January 2004). Assigning Experimental and Testing Numbers Considered Useful. Network Working Group. BCP 82. RFC 3692. https://tools.ietf.org/html/rfc3692. Best Current Practice 82. Updates RFC 2434.
  13. ↑ “Internet Protocol Version 6 (IPv6) Parameters: Routing Types”. IANA. 2021년 10월 15일에 확인함.
  14. ↑ Philippe Biondi, Arnoud Ebalard (April 2007). “IPv6 Routing Header Security” (PDF). EADS. 2010년 12월 3일에 확인함. Type 0: the evil mechanism...
  15. ↑ J. Abley; P. Savola; G. Neville-Neil (December 2007). Deprecation of Type 0 Routing Headers in IPv6. Network Working Group. RFC 5095. https://tools.ietf.org/html/rfc5095. Proposed Standard. Updates RFC 2460 and 4294.
  16. ↑ I. Castineyra; N. Chiappa; M. Steenstrup (August 1996). The Nimrod Routing Architecture. RFC 1992. https://tools.ietf.org/html/rfc1992. Informational.
  17. ↑ J. Hui; JP. Vasseur; D. Culler; V. Manral (March 2012). An IPv6 Routing Header for Source Routes with the Routing Protocol for Low-Power and Lossy Networks (RPL). Internet Engineering Task Force. RFC 6554. https://tools.ietf.org/html/rfc6554. Proposed Standard.
  18. ↑ S. Previdi; J. Leddy; S. Matsushima; D. Voyer (March 2020). C. Filsfils; D. Dukes. eds. IPv6 Segment Routing Header (SRH). Internet Engineering Task Force. ISSN 2070-1721. RFC 8754. https://tools.ietf.org/html/rfc8754. Proposed Standard.
  19. ↑ S. Kent (December 2005). IP Authentication Header. Network Working Group. RFC 4302. https://tools.ietf.org/html/rfc4302. Proposed Standard. Obsoletes RFC 2402.
  20. ↑ S. Kent (December 2005). IP Encapsulating Security Payload. Network Working Group. RFC 4303. https://tools.ietf.org/html/rfc4303. Proposed Standard. Obsoletes RFC 2406.
  21. 1 2 F. Gont; V. Manral; R. Bonica (January 2014). Implications of Oversized IPv6 Header Chains. Internet Engineering Task Force. ISSN 2070-1721. RFC 7112. https://tools.ietf.org/html/rfc7112. Proposed Standard. Updates RFC 2460.
  22. ↑ F. Gont (February 2014). Implementation Advice for IPv6 Router Advertisement Guard (RA-Guard). Internet Engineering Task Force. ISSN 2070-1721. RFC 7113. https://tools.ietf.org/html/rfc7113. Informational. Updates RFC 6105.
  23. ↑ F. Gont (August 2013). Security Implications of IPv6 Fragmentation with IPv6 Neighbor Discovery. Internet Engineering Task Force. ISSN 2070-1721. RFC 6980. https://tools.ietf.org/html/rfc6980. Proposed Standard. Updates RFC 3971 and 4861.